[Solved][2.2] New build scripts fail to build: CMake does not find dependencies

Problems building or running the engine, queries about how to use features etc.
Post Reply
LukasBoersma
Gnoblar
Posts: 2
Joined: Tue Aug 20, 2019 12:58 pm

[Solved][2.2] New build scripts fail to build: CMake does not find dependencies

Post by LukasBoersma » Tue Aug 20, 2019 1:33 pm

Ogre version: v2-2 branch
Operating system: Windows 10

I am really happy that we have the new quickstart build scripts now. This is a great improvement for the usability of the whole engine in my opinion.

However, it does not compile on my Windows machine. I am using Windows 10 (64 bit) with Visual Studio 2017 and CMake 3.14.4.

At first, it finished with the message "Done!" when it actually had not cloned any repository because hg was not in my Path environment variable. I fixed that and now I get cmake errors. When building ogre, CMake does not find the dependencies that the script built from the ogredeps repository.

Below is an excerpt from the console output that shows one of the errors. The full output is available here.

Code: Select all

--- Running CMake configure ---
-- Selecting Windows SDK version 10.0.17763.0 to target Windows 6.1.7601.
-- The C compiler identification is MSVC 19.16.27031.1
-- The CXX compiler identification is MSVC 19.16.27031.1
-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.16.27023/bin/Hostx86/x64/cl.exe
-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.16.27023/bin/Hostx86/x64/cl.exe -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.16.27023/bin/Hostx86/x64/cl.exe
-- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.16.27023/bin/Hostx86/x64/cl.exe -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Configuring OGRE 2.2.0unstable
-- Check size of void*
-- Check size of void* - done
-- Search path: C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/ogredeps/build/ogredeps;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/build/Dependencies;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/Dependencies;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/build/../Dependencies;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/../Dependencies
-- Looking for ZLIB...
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Could not locate ZLIB
-- Looking for FreeImage...
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Could not locate FreeImage
-- Looking for FREETYPE...
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- CMAKE_PREFIX_PATH: C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/ogredeps/build/ogredeps;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/build/Dependencies;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/Dependencies;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/build/../Dependencies;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/../Dependencies
-- CMAKE_PREFIX_PATH: C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/ogredeps/build/ogredeps;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/build/Dependencies;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/Dependencies;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/build/../Dependencies;C:/Users/lukas/Documents/Code/build-ogre2/Ogre/ogre/../Dependencies
-- Could not locate FREETYPE
-- Looking for Rapidjson...
-- Rapidjson_PREFIX_PATH changed.
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Could NOT find Rapidjson (missing: Rapidjson_INCLUDE_DIR) 
-- Could not locate Rapidjson
-- Found OpenGL: opengl32   
-- Looking for DirectX9...
-- DirectX9_PREFIX_PATH changed.
-- Found DirectX9: C:/Program Files (x86)/Microsoft DirectX SDK (June 2010)/Lib/x64/d3d9.lib
-- Looking for DirectX11...
-- Found DirectX11 headers: C:/Program Files (x86)/Windows Kits/10/Include/10.0.17763.0/um
-- Found DirectX11: d3d11.lib;dxgi.lib;dxguid.lib
-- Looking for AMDAGS...
-- AMDAGS_PREFIX_PATH changed.
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Could not locate AMDAGS
-- Looking for Remotery...
-- Remotery_PREFIX_PATH changed.
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Could NOT find Remotery (missing: Remotery_INCLUDE_DIR Remotery_LIBRARIES) 
-- Could not locate Remotery
-- Looking for Cg...
-- Cg_PREFIX_PATH changed.
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Could not locate Cg
-- Looking for POCO...
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Could not locate POCO
-- Looking for TBB...
-- Could not locate TBB
-- Looking for GLSL_Optimizer...
-- GLSL_Optimizer_PREFIX_PATH changed.
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Could not locate GLSL_Optimizer
-- Looking for HLSL2GLSL...
-- HLSL2GLSL_PREFIX_PATH changed.
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Could not locate HLSL2GLSL
-- Looking for OIS...
-- OIS_PREFIX_PATH changed.
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Could not locate OIS
-- Found Threads: TRUE  
-- Could NOT find SDL2 (missing: SDL2_LIBRARY SDL2_INCLUDE_DIR) 
-- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE) 
-- Looking for Softimage...
-- Softimage_PREFIX_PATH changed.
-- Could not locate Softimage
-- Could NOT find TinyXML (missing: TINYXML_INCLUDE_DIR TINYXML_LIBRARIES) 
-- Looking for CppUnit...
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 
-- Could not locate CppUnit
-- 
-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
+ OpenGL
+ OpenGL 3+
+ OpenGL ES 1.x
+ OpenGL ES 2.x
+ OpenGL ES 3.x
+ DirectX9
+ DirectX11
-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
+ zlib: Simple data compression library <http://www.zlib.net>
+ freeimage: Support for commonly used graphics image formats <http://freeimage.sourceforge.net>
+ freetype: Portable font engine <http://www.freetype.org>
+ rapidjson: C++ JSON parser <http://rapidjson.org/>
+ AMDAGS: Use AMD GPU Services library to provide D3D vendor extensions <https://gpuopen.com/gaming-product/amd-gpu-services-ags-library/>
+ Remotery: Realtime CPU/D3D/OpenGL/CUDA/Metal Profiler in a single C file with web browser viewer <https://github.com/Celtoys/Remotery>
+ cg: C for graphics shader language <http://developer.nvidia.com/object/cg_toolkit.html>
+ boost: Boost (general) <http://boost.org>
+ boost-thread: Used for threading support <http://boost.org>
+ boost-date_time: Used for threading support <http://boost.org>
+ POCO: POCO framework <http://pocoproject.org/>
+ tbb: Threading Building Blocks <http://www.threadingbuildingblocks.org/>
+ GLSL Optimizer: GLSL Optimizer <http://github.com/aras-p/glsl-optimizer/>
+ HLSL2GLSL: HLSL2GLSL <http://hlsl2glslfork.googlecode.com/>
+ OIS: Input library needed for the samples <http://sourceforge.net/projects/wgois>
+ SDL2: Simple DirectMedia Library <https://www.libsdl.org/>
+ Doxygen: Tool for building API documentation <http://doxygen.org>
+ Softimage: Softimage SDK needed for building XSIExporter <FALSE>
+ TinyXML: TinyXML needed for building OgreXMLConverter <FALSE>
+ CppUnit: Library for performing unit tests <http://cppunit.sourceforge.net>
-----------------------------------------------------------------------------

-- Could not find dependency for samples: SDL2
-- Samples require Overlays (OGRE_BUILD_COMPONENT_OVERLAY) to be set.
-- Skipping samples & tests build
-- 
----------------------------------------------------------------------------
  FEATURE SUMMARY
----------------------------------------------------------------------------

Building components:
  + MeshLodGenerator
Building plugins:
  + Particle FX
Building rendersystems:
  + Direct3D 11
  + OpenGL 3.3+
Building executables:
  + Samples
  + Tests
  + Tools
Building core features:
  + Mesh Lod
  + DDS image codec

Build type:                      dynamic
Threading support:               none
Use double precision:            disabled
Assert mode:                     standard
Allocator type:                  standard
STL containers use allocator:    enabled
Strings use allocator:           disabled
Memory tracker (debug):          disabled
Memory tracker (release):        disabled
Use 1_x legacy animations:       enabled
Use Boost:                       disabled
Use SIMD (SSE2):                 enabled
Use SIMD (NEON):                 enabled

----------------------------------------------------------------------------

-- Configuring incomplete, errors occurred!
In case anybody wants to look into it, here is are the generated build files after executing the script (670MB zip file).

Has anybody managed to build Ogre 2.x with these new scripts on Windows and knows what I am missing? Thanks for your help!
Last edited by LukasBoersma on Sun Aug 25, 2019 9:58 pm, edited 1 time in total.
0 x

User avatar
dark_sylinc
OGRE Team Member
OGRE Team Member
Posts: 4119
Joined: Sat Jul 21, 2007 4:55 pm
Location: Buenos Aires, Argentina
x 245
Contact:

Re: [2.2] New build scripts fail to build: CMake does not find dependencies

Post by dark_sylinc » Wed Aug 21, 2019 2:44 am

Hi!

Thanks for trying the scripts. It really helps!
Could you try the attached download script instead?

If that one works, I'll update all of them

Btw, where is your hg.exe located?
Attachments
build_ogre_Visual_Studio_15_2017_x64.bat.zip
(894 Bytes) Downloaded 6 times
0 x

LukasBoersma
Gnoblar
Posts: 2
Joined: Tue Aug 20, 2019 12:58 pm

Re: [2.2] New build scripts fail to build: CMake does not find dependencies

Post by LukasBoersma » Wed Aug 21, 2019 1:32 pm

Yes, that works! Thanks for the quick help :)

My hg.exe is located at "C:\Program Files\TortoiseHg\hg.exe". I installed it from the mercurial website. Apparently the officialy recommended mercurial setup for windows is to use TortoiseHg.
0 x

Post Reply