Issue render with Ogre3D and Pure OpenGL (QOpenGLWidget) in 2 separete QWidget within a Qt Application

Discussion area about developing or extending OGRE, adding plugins for it or building applications on it. No newbie questions please, use the Help forum for that.
Post Reply
khuong_nv2
Gnoblar
Posts: 1
Joined: Fri Jan 12, 2024 4:04 am

Issue render with Ogre3D and Pure OpenGL (QOpenGLWidget) in 2 separete QWidget within a Qt Application

Post by khuong_nv2 »

System Information

  • Ogre Version: v1.12.10
  • Operating System / Platform: Ubuntu 22.04
  • RenderSystem: OpenGL

Detailled description[/b]
I am encourerting a significant rendering problem when using Ogre3D and pure opengl (QOpenGLWidget) simultaneously on 2 separate QWidget withing a single Qt application.

Steps to reproduct:

  1. Create a Qt application with at least two widgets
  2. Integrate Ogre3D on one widget and QOpenGLWidget on another.
  3. Attempt to render context on both widgets simultaneously.

The render process on QOpenGLWidget is too lag.
Please let me know if any further details or clarification is needed to address and resolve this rendering issue

paroj
OGRE Team Member
OGRE Team Member
Posts: 1986
Joined: Sun Mar 30, 2014 2:51 pm
x 1065
Contact:

Re: Issue render with Ogre3D and Pure OpenGL (QOpenGLWidget) in 2 separete QWidget within a Qt Application

Post by paroj »

Ogre was not designed for cooperative rendering with another OpenGL renderer. It is possible though, but you must take care. See:
viewtopic.php?t=97150

Post Reply